DevListDump.txt LF but no CR; "Dump Translation Table" inop

You can either use the bug tracker or describe the anomaly here.

DevListDump.txt LF but no CR; "Dump Translation Table" inop

Postby Wook » 22, 2010 Feb Mon 11:06 pm

1) Not really a bug per se; more of an enhancement perhaps.

Tools -> Special -> Dump Built-in device list to file...

Some users of WxPic may be surprised at the appearance of DevListDump.txt when they open it using Notepad.
While they can open it using WordPad, or 3rd party utilities like Notepad++ and have it display correctly, a novice might think they've done something wrong, and not know how or where to report the problem.

Adding a CR to each line in the dump routine should be an easy fix. (Or maybe it's that CR exists, but LF doesn't - it's been too long since I've written any C code for file I/O).

2) Tools -> Special -> Dump Translation table to file...

This option doe not appear to do anything; generates no messages nor file that I can find.
Is this a bug, or a feature?
Wook
 
Posts: 7
Joined: 18, 2010 Feb Thu 6:24 pm

Re: DevListDump.txt LF but no CR; "Dump Translation Table" inop

Postby admin » 01, 2010 Mar Mon 10:42 pm

I have reproduced the first issue and created the report #0000051. I planned it for a late version when this issue will become obsolete because the device.ini file will no longer have this form. Though it should be so easy to fix it that I may fix it earlier.

The second issue is an obsolete menu. When porting the code, I switched it to Unicode mode and to a standard method of Internationalization. The translation files are now located in the directories Lang\xx (WxPic.mo). I created the issue #0000052 to remove the menu in next version (though I can't imagine a less critical issue :lol: ).
admin
Site Admin
 
Posts: 153
Joined: 12, 2009 Jul Sun 7:20 pm


Return to WxPic bug reporting

Who is online

Users browsing this forum: No registered users and 0 guests

cron