Beginner Windows 7 Help!

Problems or tips related to the use of WxPic

Beginner Windows 7 Help!

Postby Suleman » 18, 2011 Jun Sat 2:20 pm

Hi, I'm a beginner running WxPIC for the first time on windows7 I have a serial JDM Programmer on COM2 (Serial Port), When I connect the programmer and start tWxPIC (in administrator mode ofcourse), i get the error Unable to initialze programmer, the log shows:

19:19:30.83 Info: Parsing argument from command line
Failed read back of DATA line (HIGH) !
19:19:30.278 WARNING: Could not initialize programmer !
Testing: delay(500ms) took 0.50 seconds, timer_freq=2.6044 MHz ... ok

I read the forum post from one year ago, in which someone else had the same problem, but I don't see how they solved it.
Any help?

I
Suleman
 
Posts: 1
Joined: 18, 2011 Jun Sat 2:11 pm

Re: Beginner Windows 7 Help!

Postby admin » 18, 2011 Jun Sat 6:10 pm

Hello,

I have never tested WxPic under Windows 7 but I believe that there should be no problem with the COM ports (I would not have said the same with LPT port). To access COM port, WxPic is using standard Window API that should work with any Window version (even without admin priviledges).

From the log, it looks like if the programmer is not working properly (or not plugged to the COM2 port!).
Another hypothesis is that the COM port could be too slow. You can test if there is a speed issue from Interface panel:
Check and uncheck the Data to PIC checkbox and verify if the value of Data In pin (just below) is switching forth and back from 0 to 1.
If the bit is switching your port is too slow or has too low voltage level.

Regards,
Philippe
admin
Site Admin
 
Posts: 153
Joined: 12, 2009 Jul Sun 7:20 pm


Return to WxPic Usage

Who is online

Users browsing this forum: No registered users and 1 guest

cron